问题表现:运行程序时出现错误提示:/path/to/libstdc++.so.6: 'CXXABI_1.3.11' not found (required by xxx)

原因:如果机器上有多个GCC版本,可能是编译使用的动态库版本和运行时需要的动态库版本不同。

排查方式:查看编译命令,确认使用的编译器版本是否符合期望。

临时解决方式(不治本):通过export LD_LIBRARY_PATH的方式临时指定希望使用哪个版本的动态库,如export LD_LIBRARY_PATH=/opt/tiger/gcc-8/lib64/​